Answer : LAB 3 – Dynamic routing protocols

Answer : LAB 3 – Dynamic routing protocols:



In this LAB, we will examine features, which are common to all interior Gateway Protocols. Basic configuration for various IGPs is included but is not the focus of this LAB exercise.


Routing Protocol Updates:

  • Enter the commands on each router to provision a basic RIPv1 configuration and enable RIP on every interface:

Rx(config)#router rip 
Rx(config-router)#network 10.0.0.0
Rx(config-router)#no auto-summary 
Rx(config-router)#end


  • Debug the routing protocol updates on R1.Observe the updates being sent and receive. What kind of traffic is used (unicast, broadcast or multicast).

R1#debug ip rip 
RIP protocol debugging is on
R1#
*Feb 4 09:17:02.476: RIP: sending v1 update to 255.255.255.255 via Ethernet0/0 (10.1.0.1)
*Feb 4 09:17:02.476: RIP: build update entries
*Feb 4 09:17:02.476: subnet 10.0.0.0 metric 1
*Feb 4 09:17:02.476: subnet 10.0.1.0 metric 2
*Feb 4 09:17:02.476: subnet 10.0.2.0 metric 2
*Feb 4 09:17:02.476: subnet 10.0.3.0 metric 2

RIP: sending v1 update to 255.255.255.255:  route are send in broadcast.

  • Enter the command to enable RIPv2 on every router.

R1(config)#router
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#end

R1#debug ip rip
RIP protocol debugging is on
R1#
*Feb 4 09:45:32.109: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (10.0.0.1)
*Feb 4 09:45:32.109: RIP: build update entries
*Feb 4 09:45:32.109: 10.0.1.0/24 via 0.0.0.0, metric 1, tag 0
*Feb 4 09:45:32.109: 10.0.2.0/24 via 0.0.0.0, metric 1, tag 0
*Feb 4 09:45:32.109: 10.0.3.0/24 via 0.0.0.0, metric 1, tag 0
*Feb 4 09:45:32.109: 10.1.2.0/24 via 0.0.0.0, metric 3, tag 0
*Feb 4 09:45:32.109: 10.1.3.0/24 via 0.0.0.0, metric 2, tag 0

  • What kind of traffic used for the updates now:

RIP: sending v2 update to 224.0.0.9 route are send in multicast 224.0.0.9.

  • Turn off all debugging on R1.
R1#undebug all
All possible debugging has been turned off

  • Check that RIP routes have been added to R1 and it has a route to every subnet in lab.

R1#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area 
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
a – application route
+ – replicated route, % – next hop override
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
C 10.0.0.0/24 is directly connected, Ethernet0/0
L 10.0.0.1/32 is directly connected, Ethernet0/0
C 10.0.1.0/24 is directly connected, Ethernet0/2
L 10.0.1.1/32 is directly connected, Ethernet0/2
C 10.0.2.0/24 is directly connected, Ethernet0/3
L 10.0.2.1/32 is directly connected, Ethernet0/3
C 10.0.3.0/24 is directly connected, Ethernet0/1
L 10.0.3.1/32 is directly connected, Ethernet0/1
R 10.1.0.0/24 [120/1] via 10.0.0.2, 00:00:18, Ethernet0/0
R 10.1.1.0/24 [120/2] via 10.0.3.2, 00:00:01, Ethernet0/1
[120/2] via 10.0.0.2, 00:00:18, Ethernet0/0
R 10.1.2.0/24 [120/2] via 10.0.3.2, 00:00:01, Ethernet0/1
R 10.1.3.0/24 [120/1] via 10.0.3.2, 00:00:01, Ethernet0/1

  • Why are there two routes to the 10.1.1.0/24 network in the routing table?

R 10.1.1.0/24 [120/2] via 10.0.3.2, 00:00:01, Ethernet0/1
[120/2] via 10.0.0.2, 00:00:18, Ethernet0/0

Two paths to 10.1.1.0/24 have an equal metric – a hop count of 2. Both routes are installed in the routing table and the router will perform Equal Cost Load balancing between the next hops of 10.0.3.2 and 10.0.0.2.


Comparing routing protocols:


  • View the RIP database on R1.

R1#show ip rip database 
10.0.0.0/8 auto-summary
10.0.0.0/24 directly connected, Ethernet0/0
10.0.1.0/24 directly connected, Ethernet0/2
10.0.2.0/24 directly connected, Ethernet0/3
10.0.3.0/24 directly connected, Ethernet0/1
10.1.0.0/24
[1] Via 10.0.0.2, 00:00:02, Ethernet0/0
10.1.1.0/24
[2] Via 10.0.3.2, 00:00:14, Ethernet0/1
[2] Via 10.0.0.2, 00:00:02, Ethernet0/0
10.1.2.0/24
[2] Via 10.0.3.2, 00:00:14, Ethernet0/1
10.1.3.0/24
[1] Via 10.0.3.2, 00:00:14, Ethernet0/1

  • Enter the commands on each router to provision a basic OSPF configuration and enable OSPF on every interfaces.

Rx(config)#router ospf 1
Rx(config-router)#network 10.0.0.0 0.255.255.255 area 0

  • Are RIP routes included in the routing table on R1? Why or Why not?

R1#show ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
C 10.0.0.0/24 is directly connected, Ethernet0/0
L 10.0.0.1/32 is directly connected, Ethernet0/0
C 10.0.1.0/24 is directly connected, Ethernet0/2
L 10.0.1.1/32 is directly connected, Ethernet0/2
C 10.0.2.0/24 is directly connected, Ethernet0/3
L 10.0.2.1/32 is directly connected, Ethernet0/3
C 10.0.3.0/24 is directly connected, Ethernet0/1
L 10.0.3.1/32 is directly connected, Ethernet0/1
O 10.1.0.0/24 [110/20] via 10.0.0.2, 00:01:14, Ethernet0/0
O 10.1.1.0/24 [110/30] via 10.0.3.2, 00:00:18, Ethernet0/1
[110/30] via 10.0.0.2, 00:01:04, Ethernet0/0
O 10.1.2.0/24 [110/30] via 10.0.3.2, 00:00:18, Ethernet0/1
O 10.1.3.0/24 [110/20] via 10.0.3.2, 00:00:18, Ethernet0/1


The RIP routes are replaced by OSPF because its AD administrative Distance of 110 is preferred to RIP’s AD of 120.


  • Disable interface Ethernet 0/1 on R2. What do you expect to happen to R1’s Routing table?

R2(config)#interface ethernet 0/1
R2(config-if)#shutdown

  • Verify your expected changes to R1’s routing table.

R1#show ip route ospf
Gateway of last resort is not set

O 10.1.0.0/24 [110/40] via 10.0.3.2, 00:00:28, Ethernet0/1
O 10.1.1.0/24 [110/30] via 10.0.3.2, 00:07:41, Ethernet0/1
O 10.1.2.0/24 [110/30] via 10.0.3.2, 00:07:41, Ethernet0/1
O 10.1.3.0/24 [110/20] via 10.0.3.2, 00:07:41, Ethernet0/1


  • Aside from the next hop address, what else has changed on the routing table?

The new route have a higher metric:

O 10.1.0.0/24 [110/40] via 10.0.3.2, 00:00:28, Ethernet0/1
O 10.1.1.0/24 [110/30] via 10.0.3.2, 00:07:41, Ethernet0/1
O 10.1.2.0/24 [110/30] via 10.0.3.2, 00:07:41, Ethernet0/1
O 10.1.3.0/24 [110/20] via 10.0.3.2, 00:07:41, Ethernet0/1

  • View the OSPF database on R1. What is different it and the RIP database?
RIP : is a Distance Vector routing protocol so it only know its directly connected neighbors and the lists of networks those neighbors have advertised.
OSPF: is a link state routing protocol so it knows the state of every link on every router in its area.
R1#show ip ospf database

Link ID ADV Router Age Seq# Checksum Link count
10.0.3.1 10.0.3.1 287 0x80000004 0x0086F8 4
10.1.0.1 10.1.0.1 327 0x80000003 0x007482 1
10.1.1.2 10.1.1.2 802 0x80000003 0x00427A 2
10.1.3.2 10.1.3.2 758 0x80000001 0x008C28 2
203.0.113.1 203.0.113.1 760 0x80000002 0x001A19 3

Link ID ADV Router Age Seq# Checksum
10.0.3.1 10.0.3.1 757 0x80000001 0x00A55A
10.1.0.2 10.1.1.2 814 0x80000001 0x007B89
10.1.1.2 10.1.1.2 802 0x80000001 0x007A57
10.1.3.1 203.0.113.1 760 0x80000001 0x00F2AB


Routing Protocol Metrics and Administrative Distance:


  • Enter the command to remove OSPF on every router.
R1(config)#no router ospf 1
  • Will R1 still have connectivity to R4?
Yes: RIP is still running so RIP routes will replace the remove OSPF routes in the routing table.
R1#show ip route rip
Gateway of last resort is not set
R 10.1.0.0/24 [120/1] via 10.0.0.2, 00:00:14, Ethernet0/0
R 10.1.1.0/24 [120/2] via 10.0.3.2, 00:00:02, Ethernet0/1
[120/2] via 10.0.0.2, 00:00:14, Ethernet0/0
R 10.1.2.0/24 [120/2] via 10.0.3.2, 00:00:02, Ethernet0/1
R 10.1.3.0/24 [120/1] via 10.0.3.2, 00:00:02, Ethernet0/1
  • What is the metric to the 10.1.1.0/24 network on R1?

A hope count of two. 

  • Enter the commands on each router to provision a basic EIGRP configuration and enable EIGRP on every interface.
R1(config)#router eigrp 100
R1(config-router)#network 10.0.0.0 0.255.255.255
R1(config-router)#no auto-summary
  • What changes do you expect to see in the routing tables? Why?
  • Verify the changes to the routing tables on R1.
R1#show ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
C 10.0.0.0/24 is directly connected, Ethernet0/0
L 10.0.0.1/32 is directly connected, Ethernet0/0
C 10.0.1.0/24 is directly connected, Ethernet0/2
L 10.0.1.1/32 is directly connected, Ethernet0/2
C 10.0.2.0/24 is directly connected, Ethernet0/3
L 10.0.2.1/32 is directly connected, Ethernet0/3
C 10.0.3.0/24 is directly connected, Ethernet0/1
L 10.0.3.1/32 is directly connected, Ethernet0/1
D 10.1.0.0/24 [90/307200] via 10.0.0.2, 00:01:51, Ethernet0/0
D 10.1.1.0/24 [90/332800] via 10.0.3.2, 00:00:45, Ethernet0/1
[90/332800] via 10.0.0.2, 00:00:45, Ethernet0/0
D 10.1.2.0/24 [90/332800] via 10.0.3.2, 00:00:45, Ethernet0/1
D 10.1.3.0/24 [90/307200] via 10.0.3.2, 00:00:45, Ethernet0/1
The RIP routes are replaced by EIGRP because its AD administrative Distance of 90 is preferred to RIP’s AD of 120
  • What is the metric to the 10.1.1.0/24 network on R1?
A composite Metric of 332800
  • Disable RIP and EIGRP on R5.
R5(config)#no router eigrp 100
  • Configure the network so that there is still connectivity between all subnets if the link between R1 and R2 goes down. Accomplish this with six commands. Do not enable EIGRP on R5 but note that the routing protocol is expected to be enabled there in the future.
Floating static routes need to be added as a backup to the EIGRP routes. These routes would normally be preferred to the route learned via EIGRP because static routes have a better administrative distance of 1 by default. Set the AD to be higher than EIGRP’s AD of 90.
R1(config)#ip route 10.1.0.0 255.255.0.0 10.0.3.2 95
R2(config)#ip route 10.0.0.0 255.255.0.0 10.1.0.2 95
R3(config)#ip route 10.0.0.0 255.255.0.0 10.1.1.1 95
R4(config)#ip route 10.0.0.0 255.255.0.0 10.1.3.2 95
R5(config)#ip route 10.0.0.0 255.255.0.0 10.0.3.1 95
R5(config)#ip route 10.1.0.0 255.255.0.0 10.1.3.1 95
Summary routes need to be used to accomplish the task in six commands.
  • What changes do you expect to see to the routing table on R1?
The summary route will be added to the routing table but not used because it has a prefix length of /16, compared to the EIGRP routes that have a longer prefix length of /24.
  • Verify the changes to the routing table on R1.
R1#show ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 13 subnets, 3 masks
C 10.0.0.0/24 is directly connected, Ethernet0/0
L 10.0.0.1/32 is directly connected, Ethernet0/0
C 10.0.1.0/24 is directly connected, Ethernet0/2
L 10.0.1.1/32 is directly connected, Ethernet0/2
C 10.0.2.0/24 is directly connected, Ethernet0/3
L 10.0.2.1/32 is directly connected, Ethernet0/3
C 10.0.3.0/24 is directly connected, Ethernet0/1
L 10.0.3.1/32 is directly connected, Ethernet0/1
S 10.1.0.0/16 [95/0] via 10.0.3.2
D 10.1.0.0/24 [90/307200] via 10.0.0.2, 01:41:29, Ethernet0/0
D 10.1.1.0/24 [90/332800] via 10.0.0.2, 01:34:56, Ethernet0/0
D 10.1.2.0/24 [90/358400] via 10.0.0.2, 01:34:56, Ethernet0/0
D 10.1.3.0/24 [90/358400] via 10.0.0.2, 01:34:56, Ethernet0/0
  • Verify that traffic from PC1 to PC2 still goes via R2.
Pc2> trace 10.1.2.10
Trace to 10.1.2.10, 8 hops max, press Ctrl+C to stop
1 10.0.1.1 1.120 ms 1.163 ms 1.479 ms
2 10.0.0.2 1.692 ms 1.654 ms 1.599 ms
3 10.1.0.2 2.145 ms 1.787 ms 1.743 ms
4 10.1.1.1 2.090 ms 2.476 ms 2.048 ms
5 *10.1.2.10 3.580 ms (ICMP type:3, code:3, Destination port unreachable)
  • Shut down interface Ethernet0/1 on R2.
R2(config)#interface ethernet 0/1
R2(config-if)#shutdown
  • What changes do you expect to see on R1’s routing table? Verify the changes to the routing table on R1.
The EIGRP route will be removed.
R1#show ip route
10.0.0.0/8 is variably subnetted, 12 subnets, 3 masks
C 10.0.0.0/24 is directly connected, Ethernet0/0
L 10.0.0.1/32 is directly connected, Ethernet0/0
C 10.0.1.0/24 is directly connected, Ethernet0/2
L 10.0.1.1/32 is directly connected, Ethernet0/2
C 10.0.2.0/24 is directly connected, Ethernet0/3
L 10.0.2.1/32 is directly connected, Ethernet0/3
C 10.0.3.0/24 is directly connected, Ethernet0/1
L 10.0.3.1/32 is directly connected, Ethernet0/1
S 10.1.0.0/16 [95/0] via 10.0.3.2
R 10.1.1.0/24 [120/2] via 10.0.3.2, 00:00:08, Ethernet0/1
R 10.1.2.0/24 [120/2] via 10.0.3.2, 00:00:08, Ethernet0/1
R 10.1.3.0/24 [120/1] via 10.0.3.2, 00:00:08, Ethernet0/1
  • Verify the traffic goes via R5.
VPCS> trace 10.1.2.10
trace to 10.1.2.10, 8 hops max, press Ctrl+C to stop
1 10.0.1.1 0.765 ms 0.375 ms 0.656 ms
2 10.0.3.2 0.911 ms 1.010 ms 0.908 ms
3 10.1.3.1 1.271 ms 1.135 ms 1.055 ms
4 *10.1.2.10 1.768 ms (ICMP type:3, code:3, Destination port unreachable)
  • Bring interface Ethernet 0/1 on R2 back up.
R2(config)#interface ethernet 0/1
R2(config-if)#no shutdown
  • Enter the commands on R5 to provision a basic EIGRP configuration and enable EIGRP on every interface.
R5 (config)#router eigrp 100
R5 (config-router)#network 10.0.0.0 0.255.255.255
*Feb 4 12:33:53.737: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 10.0.3.1 (Ethernet0/1) is up: new adjacency
*Feb 4 12:33:53.737: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 10.1.3.1 (Ethernet0/0) is up: new adjacency
R5 (config-router) #no auto-summary
Loopback Interfaces: 

  • Configure loopback interface 0 on each router. Assign the ip address 192.168.0.x/32, where x is the router number.
R1 (config)#interface loopback 0
R1 (config-if)#ip address 192.168.0.1 255.255.255.255
R2 (config)#interface loopback 0
R2 (config-if)#ip address 192.168.0.2 255.255.255.255
R3 (config)#interface loopback 0
R3 (config-if)#ip address 192.168.0.3 255.255.255.255
R4 (config)#interface loopback 0
R4 (config-if)#ip address 192.168.0.4 255.255.255.255
R5(config)#interface loopback 0
R5(config-if)#ip address 192.168.0.5 255.255.255.255
  • Is there connectivity to the loopback interfaces from the pcs? Why or why not?
There is no connectivity from the PCs to the loopback interfaces because they are not in the routing tables of the routers (apart from the local loopback interface on each router). The loopback interfaces are not in the routing tables because they are in the 192.168.0.0/24 range which has not been included in the routing protocol.
  • Enter the commands on each router to include the loopback interfaces in EIGRP.
R1(config)#router eigrp 100
R1(config-router)#network 192.168.0.0 0.0.0.255
R2(config)#router eigrp 100
R2(config-router)#network 192.168.0.0 0.0.0.255
R3(config)#router eigrp 100
R3(config-router)#network 192.168.0.0 0.0.0.255
R4(config)#router eigrp 100
R4(config-router)#network 192.168.0.0 0.0.0.255
R5(config)#router eigrp 100
R5(config-router)#network 192.168.0.0 0.0.0.255
  • Verify the loopback interfaces are in the routing table on R1.
R1#show ip route
10.0.0.0/8 is variably subnetted, 13 subnets, 3 masks
S 10.1.0.0/16 [95/0] via 10.0.3.2
D 10.1.0.0/24 [90/307200] via 10.0.0.2, 00:16:29, Ethernet0/0
D 10.1.1.0/24 [90/332800] via 10.0.3.2, 00:15:12, Ethernet0/1
[90/332800] via 10.0.0.2, 00:15:12, Ethernet0/0
D 10.1.2.0/24 [90/332800] via 10.0.3.2, 00:15:12, Ethernet0/1
D 10.1.3.0/24 [90/307200] via 10.0.3.2, 00:15:12, Ethernet0/1
192.168.0.0/32 is subnetted, 5 subnets
C 192.168.0.1 is directly connected, Loopback0
D 192.168.0.2 [90/409600] via 10.0.0.2, 00:02:34, Ethernet0/0
D 192.168.0.3 [90/435200] via 10.0.0.2, 00:02:17, Ethernet0/0
D 192.168.0.4 [90/435200] via 10.0.3.2, 00:02:00, Ethernet0/1
D 192.168.0.5 [90/409600] via 10.0.3.2, 00:01:37, Ethernet0/1
  • Verify connectivity from PC2 to the loopback on R5.
PC2> ping 192.168.0.5
84 bytes from 192.168.0.5 icmp_seq=1 ttl=254 time=0.933 ms
84 bytes from 192.168.0.5 icmp_seq=2 ttl=254 time=2.706 ms
84 bytes from 192.168.0.5 icmp_seq=3 ttl=254 time=3.018 ms
84 bytes from 192.168.0.5 icmp_seq=4 ttl=254 time=2.680 ms
84 bytes from 192.168.0.5 icmp_seq=5 ttl=254 time=2.721 ms
Adjacencies and passive interfaces:

  • Enter the command to verify that R1 has established EIGRP adjacencies with R2 and R5.
R1#show ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.0.3.2 Et0/1 12 00:17:43 8 100 0 20
0 10.0.0.2 Et0/0 11 00:18:59 7 100 0 36
  • Enter the command to configure the loopback interface and the link to R5 as passive interface on R1.
R1(config)#router eigrp 100
R1(config-router)#passive-interface loopback 0
R1(config-router)#passive-interface ethernet 0/1
I hope you hae enjoyed guys thank you for coming and having a look!

Our Facebook Group -->Here<--

Original source here




Cisco,Cisco Press,Microsoft,Oracle,CompTIA,CIW,Adobe,ISC2,Linux,Cisco Press,e-learning,CCNA,CCNP,CCIE,HCNA,HCNP,HCIE,CCNP,CCIE,HCNA,HCNP,HCIE,bootcamp,IT certification,MCTS,MCITP,A+,Network+,Security+,Online tutorials for Internet,Networking,Security,Website Development,Network Design,Computers,Information Security,exams,free practice tests,router simulations,hands-on labs,CCNA,CCENT,ICND1,ICND2,CISCO,NETWORK,TEST QUESTIONS,PREPARATION STUDY GROUP, ccna, cisco, ccnp, ccie, networking, it, security, networkengineer, technology, mikrotik, iman, farahi, network, linux, tech, python, ccent, iot, computer, datacenter, life , informationtechnology, voip, programming, virtualization, e, developer, programmer, mtcna, bhfyp,
, ccna, cisco, ccnp, ccie, networking, it, security, networkengineer, technology, mikrotik, iman, farahi  network, linux, tech, python, ccent, iot, computer, datacenter, life, informationtechnology, voip, programming, virtualization, e, developer, programmer, mtcna, bhfyp


















No comments:

Apply For Self Study E-Learning Notes

Pages